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	14	 Collaborating 
		  with Colleagues

In this chapter, you will learn how to
✔	 Share workbooks.
✔	 Manage comments.
✔	 Track and manage colleagues’ changes.
✔	 Protect workbooks and worksheets.
✔	 Authenticate workbooks.
✔	 Save workbooks for the Web.

Even though one individual might be responsible for managing an organization’s financial 
data and related information, many people have input when making revenue projections. 
You and your colleagues can enhance the Microsoft Excel 2010 workbook data you share 
by adding comments that offer insight into the information the data represents, such as 
why revenue was so strong during a particular month or whether a service level might be 
discontinued. If the workbook in which those projections and comments will be stored 
is available on a network or an intranet, you can allow more than one user to access the 
workbook at a time by turning on workbook sharing. When a workbook has been shared 
with your colleagues, you can have the workbook mark and record any changes made to 
it. You can then decide which changes to keep and which to reject. 

If you prefer to limit the number of colleagues who can view and edit your workbooks, 
you can add password protection to a workbook, worksheet, cell range, or even an 
individual cell. Adding password protection prevents changes to critical elements of 
your workbooks. You can also hide formulas used to calculate values.
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If you work in an environment in which you and your colleagues, both inside and outside 
your organization, exchange files frequently, you can use a digital signature to help verify 
that your workbooks and any macros they contain are from a trusted source. 

Finally, if you want to display information on a Web site, you can do so by saving a work-
book as a Web page. Your colleagues won’t be able to edit the workbook, but they will 
be able to view it and comment by e-mail or phone.

In this chapter, you’ll learn how to share a workbook, manage comments in workbook 
cells, track and manage changes made by colleagues, protect workbooks and work-
sheets, digitally sign your workbooks, and save your workbooks for the Web.

Practice Files  Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter14 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Sharing Workbooks
To enable several users to edit a workbook simultaneously, you must turn on workbook 
sharing. Workbook sharing is perfect for an enterprise such as Consolidated Messenger, 
whose employees need to look up customer information, shipment numbers, and details 
on mistaken deliveries.

To turn on workbook sharing, on the Review tab, in the Changes group, click Share 
Workbook. On the Editing page of the Share Workbook dialog box, turn on workbook 
sharing by selecting the Allow Changes By More Than One User At The Same Time 
check box. You can then set the sharing options for the active workbook by clicking the 
Advanced tab.



	 Sharing Workbooks    369

Important  You can’t share a workbook that contains an Excel table. To share the workbook, 
convert the Excel table to a regular cell range by clicking the Excel table, clicking the Design 
tab and then, in the Tools group, clicking Convert To Range. Click Yes in the dialog box that 
opens to confirm the change.

On the Advanced page of the Share Workbook dialog box, two settings are of particular 
interest. The first determines whether Excel should maintain a history of changes made 
to the workbook and, if so, for how many days it should keep the history. The default 
setting is for the program to retain a record of all changes made in the past 30 days, but 
you can enter any number of days you like. If you revisit your workbook on a regular 
basis, maintaining a list of all changes for the past 180 days might not be unreasonable. 
For a workbook that changes less frequently, a history reaching back 365 days (one year) 
could meet your tracking and auditing needs. Excel deletes the record of any changes 
made earlier than the time you set.

Tip  You should find out whether your organization has an information retention policy that 
would affect the amount of time you should keep your workbooks’ change histories.

The other important setting on this page deals with how Excel decides which of two 
conflicting changes in a cell should be applied. For example, a service level’s price might 
change, and two of your colleagues might type in what they think the new price should 
be. Selecting the Ask Me Which Changes Win option enables you to decide whether to 
keep the original price or the changed price.
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There are two main ways to share a workbook with your colleagues: you can make it 
available over your organization’s network, and you can send a copy of the file to your 
colleagues via e-mail. Every organization’s network is different, so you should check with 
your network administrators to determine the best way to share a file. Similarly, although 
the specific command to attach a file to an e-mail message is different in every e-mail 
program, the most common method of attaching a file is to create a new e-mail mes-
sage and then click the Attach button, as in Microsoft Outlook 2010.

In this exercise, you’ll turn on workbook sharing and then attach the file to an Outlook 
2010 e-mail message.

Important  You must have Outlook 2010 installed on your computer to follow this procedure 
exactly.

SET UP  You need the CostProjections_start workbook located in your Chapter14 
practice file folder to complete this exercise. Start Excel, open the CostProjections_start 
workbook, and save it as CostProjections. Then start Outlook, and follow the steps. 

	 1.	 In Excel, on the Review tab, in the Changes group, click Share Workbook.

The Share Workbook dialog box opens.

	 2.	 Select the Allow changes by more than one user at the same time check box.
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Tip  Workbook merging is the process of bringing changes from several copies of a 
shared workbook into the source workbook. For more information on the topic, press 
F1 to display the Excel Help dialog box, search for workbook merging, and click the 
Merge Copies Of A Shared Workbook link.

	 3.	 Click OK.

A message box appears, indicating that you must save the workbook for the action 
to take effect.

	 4.	 Click OK.

Excel saves and shares the workbook.

	 5.	 Click the File tab, click Save & Send, and then click Send Using E-mail.

	 6.	 Click Send as Attachment.

A new e-mail message opens with the CostProjections workbook attached.

	 7.	 Type an address in the To box.

	 8.	 Click Send.

Your e-mail program sends the message. If Excel had to open your e-mail program 
to send the message, the program would close at this point.

CLEAN UP  Close the CostProjections workbook.
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Saving a Workbook for Secure Electronic Distribution

You can create a secure, read-only copy of a workbook for electronic distribution 
by saving it as a Portable Document Format (PDF) or XML Paper Specification (XPS) 
file. The controls you use to do so are available on the Save & Send page of the 
Backstage view.

Tip  You can also save a workbook as a PDF or XPS document by clicking the File tab 
and clicking Save As. Then, in the Save As dialog box, in the Save As Type list, select 
either PDF or XPS to create a file of the desired type.

To save a workbook as a PDF or XPS file:

	 1.	 Click the File tab, click Save & Send, click Create PDF/XPS Document, and then 
click the Create PDF/XPS button.

	 2.	 In the Publish As PDF Or XPS dialog box, select the file format you want.

	 3.	 If you plan to distribute the file online but not print it, click Minimum Size.

	 4.	 If you want to specify what portion of the workbook or types of content to 
publish, click the Options button, make your selections, and then click OK.

	 5.	 Click Publish.

Managing Comments
Excel makes it easy for you and your colleagues to insert comments in workbook cells, 
adding insights that go beyond the cell data. For example, if a regional processing 
center’s package volume is exceptionally high on a particular day, the center’s manager 
can add a comment to the cell in which shipments are recorded for that day, noting 
that two very large bulk shipments accounted for the disparity.

When you add a comment to a cell, a flag appears in the upper-right corner of the 
cell. When you point to a cell that contains a comment, the comment appears in a 
box next to the cell, along with the user name of the user who was logged on to the 
computer on which the comment was created.
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Important  Note that the name attributed to a comment might not be the same as the name 
of the person who actually created it. Access controls, such as those that require users to enter 
account names and passwords when they access a computer, can help track the person who 
made a comment or change.

You can add a comment to a cell by clicking the cell, clicking the Review tab, and then 
clicking New Comment. When you do, the comment flag appears in the cell, and a 
comment box appears next to the cell. You can type the comment in the box and, 
when you’re done, click another cell to close the box. When you point to the cell that 
contains the comment, the comment appears next to the cell.

If you want a comment to be shown the entire time the workbook is open, click the cell 
that contains the comment, click the Review tab and then, in the Comments group, click 
Show/Hide Comment. You can hide the comment by clicking the same button when the 
comment appears in the workbook, and delete the comment by clicking the Review tab 
and then, in the Comments group, clicking Delete. Or you can open the comment for 
editing by clicking Edit Comment in the Comments group.

Troubleshooting  The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

Important  When someone other than the original user edits a comment, that person’s input 
is marked with the new user’s name and is added to the original comment. 
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You can control whether a cell displays just the comment indicator or the indicator and 
the comment itself by clicking a cell that contains a comment and then, on the Review 
tab, clicking the Show/Hide Comment button. Clicking the Show/Hide Comment button 
again reverses your action. If you’ve just begun to review a worksheet and want to dis-
play all of the comments on the sheet, display the Review tab and click the Show All 
Comments button. To move through the worksheet’s comments one at a time, click the 
Previous or Next button.

In this exercise, you’ll add comments to two cells. You will then highlight the cells that 
contain comments, review a comment, and delete that comment.

SET UP  You need the ProjectionsForComment_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ProjectionsForComment_start 
workbook, and save it as ProjectionsForComment. Then follow the steps. 

	 1.	 Click cell E6.

	 2.	 On the Review tab, in the Comments group, click New Comment.

A red comment flag appears in cell E6, and a comment box appears next to the cell.

	 3.	 In the comment box, type Seems optimistic; move some improvement to the 
next year? 

	 4.	 Click any cell outside the comment box.

The comment box disappears.

	 5.	 Click cell G7.

	 6.	 On the Review tab, in the Comments group, click New Comment.

A red comment flag appears in cell G7, and a comment box appears next to the cell.
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	 7.	 In the comment box, type Should see more increase as we integrate new 
processes. 

	 8.	 Click any cell outside the comment box.

The comment box disappears.

	 9.	 Click cell G7.

	 10.	 On the Review tab, in the Comments group, click Delete.

Excel deletes the comment.

CLEAN UP  Save the ProjectionsForComment workbook, and then close it.

Tracking and Managing Colleagues’ Changes
Whenever you collaborate with your colleagues to produce or edit a document, you should 
consider tracking the changes each user makes. When you turn on change tracking, any 
changes made to the workbook are highlighted in a color assigned to the user who made 
the changes. One benefit of tracking changes is that if you have a question about a change, 
you can quickly identify who made the change and verify that it is correct. In Excel, you can 
turn on change tracking in a workbook by clicking the Review tab and then, in the Changes 
group, clicking Track Changes and then Highlight Changes.

In the Highlight Changes dialog box that opens, select the Track Changes While Editing check 
box. Selecting this check box saves your workbook, turns on change tracking, and also shares 
your workbook, enabling more than one user to access the workbook simultaneously. 
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You can use the commands in the Highlight Changes dialog box to choose which 
changes to track. Clearing the When, Who, and Where check boxes makes Excel track 
all changes, whereas selecting a check box and using the commands to specify a time 
frame, users, or areas of the workbook limits which changes are highlighted. Each user’s 
changes are displayed in a unique color. When you point to a cell that contains a change, 
the date and time when the change was made and the name of the user who made it 
appear as a ScreenTip.

After you and your colleagues finish modifying a workbook, anyone with permission to 
open the workbook can decide which changes to accept and which changes to reject. 
To start the process, click the Review tab. In the Changes group, click Track Changes, and 
then click Accept Or Reject Changes. After you clear the message box that indicates Excel 
will save your workbook, the Select Changes To Accept Or Reject dialog box opens. From 
the When list, you can choose which changes to review. The default choice is Not Yet 
Reviewed, but you can also click Since Date to open a dialog box in which you can enter 
the starting date of changes you want to review. To review all changes in your workbook, 
clear the When, Who, and Where check boxes.

Tip  After you and your colleagues have finished making changes, you should turn off workbook 
sharing to help ensure that you are the only person able to review the changes and decide 
which to accept.

When you are ready to accept or reject changes, click OK. The Accept Or Reject Changes 
dialog box opens and displays the first change, which is described in the body of the dialog 
box. Clicking the Accept button finalizes the change; clicking the Reject button removes the 
change, restores the cell to its previous value, and erases any record of the change. Clicking 
Accept All or Reject All finalizes all changes or restores all cells to their original values, but 
you should choose one of those options only if you are absolutely certain you are doing 
the right thing. 

Important  Clicking the Undo button on the Quick Access Toolbar or pressing Ctrl+Z will not 
undo the operation.

You can create an itemized record of all changes made since the last time you saved the 
workbook by adding a History worksheet to your workbook. To add a History worksheet, 
click Track Changes in the Changes group, and then click Highlight Changes to open the 
Highlight Changes dialog box. Select the List Changes On A New Sheet check box. When 
you click OK, a new worksheet named History opens in your workbook. Excel will delete 
the History worksheet the next time you save your workbook.
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In this exercise, you’ll turn on change tracking in a workbook, make changes to the 
workbook, accept the changes, and create a History worksheet.

SET UP  You need the ProjectionChangeTracking_start workbook 
located in your Chapter14 practice file folder to complete this exercise.  
Open the ProjectionChangeTracking_start workbook, and save it as  
ProjectionChangeTracking. Then follow the steps. 

	 1.	 On the Review tab, in the Changes group, click Track Changes, and then click 
Highlight Changes.

The Highlight Changes dialog box opens.

	 2.	 Select the Track changes while editing check box to activate the Highlight 
which changes area, and clear the When check box.

	 3.	 Click OK.

A message box appears, indicating that Excel will save the workbook.

	 4.	 Click OK.

The message box closes. Excel saves the workbook and begins tracking changes.

	 5.	 In cell E6, type 16%, and then press Enter.

A blue flag appears in the upper-left corner of cell E6.

	 6.	 In cell E7, type 14%, and then press Enter.

A blue flag appears in the upper-left corner of cell E7.
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	 7.	 On the Quick Access Toolbar, click the Save button to save your work.

	 8.	 On the Review tab, in the Changes group, click Track Changes, and then click 
Highlight Changes.

The Highlight Changes dialog box opens.

	 9.	 Select the List changes on a new sheet check box, clear the When check box, and 
then click OK.

Excel creates and displays a worksheet named History, which contains a list of all 
changes made since the last time a user accepted or rejected changes.

	 10.	 Click the Sheet1 sheet tab.

The Sheet1 worksheet opens.

	 11.	 On the Review tab, in the Changes group, click Track Changes, and then click 
Accept/Reject Changes.

The Select Changes To Accept Or Reject dialog box opens.

	 12.	 Click OK.

The Accept Or Reject Changes dialog box displays the first change.
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	 13.	 Click Accept.

Excel keeps the change and then displays the next change.

	 14.	 Click Accept.

Excel keeps the change and deletes the History worksheet. The Accept Or Reject 
Changes dialog box closes.

CLEAN UP  Save the ProjectionChangeTracking workbook, and then close it.

Protecting Workbooks and Worksheets
Excel gives you the ability to share your workbooks over the Web, over a corporate intranet, 
or by copying files for other users to take on business trips. An important part of sharing 
files, however, is ensuring that only those users you want to have access to the files can 
open or modify them. For example, Consolidated Messenger might have a series of com-
puters available in a processing center so supervisors can look up package volumes and 
handling efficiency information. Although those computers are vital tools for managing 
the business process, it doesn’t help the company to have unauthorized personnel, even 
those with good intentions, accessing critical workbooks.

You can limit access to your workbooks or elements within workbooks by setting passwords. 
When you set a password for an Excel workbook, any users who want to access the protected 
workbook must enter the workbook’s password in a dialog box that opens when they try to 
open the file. If users don’t know the password, they cannot open the workbook.

To set a password for a workbook, open the workbook to be protected, and click the File 
tab to display the workbook in the Backstage view. Then, on the Info page of the Backstage 
view, click the Protect Workbook button and then click Encrypt With Password. The Encrypt 
Document dialog box opens, with a Password box in which you can type your password. After 
you click OK, the Confirm Password dialog box opens, in which you can verify the password 
required to open the workbook. After you have confirmed the password, click OK. Now the 
Info page of the Backstage view indicates that users must enter a password to open the file.
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To remove the passwords from a workbook, repeat these steps, but delete the passwords 
from the Encrypt Document dialog box and save the file.

Tip  The best passwords are long strings of random characters, but random characters are 
hard to remember. One good method of creating hard-to-guess passwords is to base your 
password on a longer phrase. For example, “I learned about passwords in Chapter 14 of 
Microsoft Excel 2010 Step by Step” could translate to the password IlapiC14oME2SbS. In any 
event, avoid dictionary words in English or any other language, because they can be found 
easily by password-guessing programs available on the Internet; include both uppercase 
and lowercase letters; and use characters other than letters or numbers if possible.

If you want to allow anyone to open a workbook but want to prevent unauthorized 
users from editing a worksheet, you can protect a worksheet by displaying that work-
sheet, clicking the Review tab and then, in the Changes group, clicking Protect Sheet 
to open the Protect Sheet dialog box.
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In the Protect Sheet dialog box, you select the Protect Worksheet And Contents Of Locked 
Cells check box to protect the sheet. You can also set a password that a user must type in 
before protection can be turned off again and choose which elements of the worksheet a 
user can change while protection is turned on. To enable a user to change a worksheet 
element without entering the password, select the check box next to that element’s name.

The check box at the top of the worksheet mentions locked cells. A locked cell is a cell that 
can’t be changed when worksheet protection is turned on. You can lock or unlock a cell by 
right-clicking the cell and clicking Format Cells on the shortcut menu that appears. In the 
Format Cells dialog box, you click the Protection tab and select the Locked check box.

When worksheet protection is turned on, selecting the Locked check box prevents unauthor- 
ized users from changing the contents or formatting of the locked cell, whereas selecting the 
Hidden check box hides the formulas in the cell. You might want to hide the formula in a cell 
if you draw sensitive data, such as customer contact information, from another workbook 
and don’t want casual users to see the name of the workbook in a formula.

Finally, you can password-protect a cell range. For example, you might want to let users 
enter values in most worksheet cells but also want to protect the cells with formulas that 
perform calculations based on those values. To password-protect a range of cells, select 
the cells to protect, click the Review tab and then, in the Changes group, click Allow 
Users To Edit Ranges. The Allow Users To Edit Ranges dialog box opens.
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To create a protected range, click the New button to display the New Range dialog 
box. Type a name for the range in the Title box, and then type a password in the Range 
Password box. When you click OK, Excel asks you to confirm the password; after you do, 
click OK in the Confirm Password dialog box and again in the Allow Users To Edit Ranges 
dialog box to protect the range. Now, whenever users try to edit a cell in the protected 
range, they are prompted for a password. 

Tip  Remember that a range of cells can mean just one cell!

In this exercise, you’ll password-protect a workbook, a worksheet, and a range of cells. 
You will also hide the formula in a cell.

SET UP  You need the SecureInfo_start workbook located in your Chapter14 practice 
file folder to complete this exercise. Open the SecureInfo_start workbook, and save it 
as SecureInfo. Then follow the steps. 

	 1.	 Click the File tab, and then, if necessary, click Info.

The Info page of the Backstage view is displayed.

	 2.	 Click the Protect Workbook button, and then click Encrypt with Password.

The Encrypt Document dialog box opens.
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	 3.	 Type work14pro in the Password box.

	 4.	 Click OK.

The Confirm Password dialog box opens.

	 5.	 In the Reenter password box, type work14pro.

	 6.	 Click OK.

The Confirm Password dialog box closes.

	 7.	 Click the Review tab of the ribbon and, if necessary, click the Performance 
sheet tab.

The Performance worksheet opens.

	 8.	 Right-click cell B8, and then click Format Cells.

The Format Cells dialog box opens.

	 9.	 Click the Protection tab.

The Protection page is displayed.

	 10.	 Select the Hidden and Locked check boxes, and then click OK.

Excel formats cell B8 so that it won’t display its formula after you protect the 
worksheet.
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	 11.	 On the Review tab, in the Changes group, click Protect Sheet.

The Protect Sheet dialog box opens.

	 12.	 In the Password to unprotect sheet box, type prot300pswd.

	 13.	 Clear the Select locked cells and Select unlocked cells check boxes, and then 
click OK.

The Confirm Password dialog box opens.

	 14.	 In the Reenter password to proceed box, type prot300pswd, and then click OK.

	 15.	 Click the Weights sheet tab.

The Weights worksheet opens.

	 16.	 Select the cell range B2:C7.

	 17.	 On the Review tab, in the Changes group, click Allow Users to Edit Ranges.

The Allow Users To Edit Ranges dialog box opens.

	 18.	 Click New.

The New Range dialog box opens, with the range B2:C7 displayed in the Refers To 
Cells box.

	 19.	 In the Title box, type AllWeights.

	 20.	 In the Range password box, type work14pro, and then click OK.

	 21.	 In the Confirm Password dialog box, reenter the password work14pro.

The range appears in the Allow Users To Edit Ranges box.

	 22.	 Click Protect Sheet.

The Protect Sheet dialog box opens.

	 23.	 In the Password to unprotect sheet box, type work14pro, and then click OK.

	 24.	 In the Confirm Password dialog box, reenter the password work14pro, and then 
click OK.

CLEAN UP  Save the SecureInfo workbook, and then close it.
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Finalizing a Workbook

Distributing a workbook to other users carries many risks, not the least of which 
is the possibility that the workbook might contain private information you don’t 
want to share with users outside your organization. With Excel, you can inspect a 
workbook for information you might not want to distribute to other people, and 
create a read-only final version that prevents other people from making changes 
to the workbook content.

Using the Document Inspector, you can quickly locate comments and annotations, 
document properties and personal information, custom XML data, headers and 
footers, hidden rows and columns, hidden worksheets, and invisible content. You 
can then easily remove any hidden or personal information that the Document 
Inspector finds.

To inspect and remove hidden or personal information, follow these steps:

	 1.	 Save the file.

	 2.	 Click the File tab, and then, on the Info page of the Backstage view, click Check 
for Issues, and then click Inspect Document.

	 3.	 In the Document Inspector window, clear the check box of any content type 
you want to remain in the document, and click Inspect.

	 4.	 In the inspection results list, click the Remove All button to the right of any 
category of data you want to remove.

Marking a workbook as final sets the status property to Final and turns off data entry, 
editing commands, and proofreading marks.

To mark a workbook as final, follow these steps:

	 1.	 Click the File tab, and then, on the Info page of the Backstage view, click 
Protect Workbook, and then click Mark as Final.

	 2.	 In the message box indicating that the file will be marked as final and then 
saved, click OK.

	 3.	 In the message box indicating that the file has been marked as final, click OK.

To restore functionality to a workbook that has been marked as final, click the File tab 
and then, on the Info page of the Backstage view, click Protect Workbook, and then 
click Mark As Final to change its status.
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Authenticating Workbooks
The unfortunate reality of exchanging files over networks, especially over the Internet, is 
that you need to be sure you know the origin of the files you’re working with. One way 
an organization can guard against files with viruses or substitute data is to authenticate 
every workbook using a digital signature. A digital signature is a character string created 
by combining a user’s unique secret digital signature file mathematically with the contents 
of the workbook, which programs such as Excel can recognize and use to verify the iden-
tity of the user who signed the file. A good analogy for a digital signature is a wax seal, 
which was used for thousands of years to verify the integrity and origin of a document.

Tip  The technical details of and procedure for managing digital certificates are beyond the 
scope of this book, but your network administrator should be able to create a digital certificate 
for you. You can also directly purchase a digital signature from a third party, which can usually 
be renewed annually for a small fee. For the purposes of this book, you’ll use the selfcert.exe 
Microsoft Office accessory program to generate a certificate with which to perform the exercise 
at the end of this topic. This type of certificate is useful for certifying a document as part of a 
demonstration, but other users will not accept it as a valid certificate to verify that the contents 
of the document haven’t changed since it was signed.

To create a digital certificate that you can use as a demonstration, open the Start menu, 
click All Programs, click Microsoft Office, click Microsoft Office 2010 Tools, and then click 
Digital Certificate For VBA Projects. In the Create Digital Certificate dialog box, type a 
name for your certificate and click OK to have the program create your trial certificate. 
Then, in Excel, click the File tab and on the Info page of the Backstage view, click Protect 
Workbook and then click Add A Digital Signature. In the Sign dialog box, type your 
purpose for signing the document, and then click Sign to sign your workbook.

Tip  After you click Add A Digital Signature, Excel displays a dialog box, indicating that you can 
buy digital signatures from third-party providers. To get information about those services, click 
the Signature Services From The Office Marketplace button. To bypass the message, click OK; to 
prevent the dialog box from appearing again, select the Don’t Show This Message Again check 
box, and then click OK.

If you have several certificates from which to choose, and the desired certificate doesn’t 
appear in the Sign dialog box, you can click Change to display the Select Certificate 
dialog box. In the Select Certificate dialog box, click the certificate with which you 
want to sign the workbook, and then click OK. The Select Certificate dialog box closes, 
and the certificate with which you signed the workbook appears in the Sign dialog 
box. As before, click Sign to sign your document by using the digital certificate.

In this exercise, you’ll create a digital certificate and digitally sign a workbook by using 
the certificate.
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SET UP  You need the ProjectionsSigned_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ProjectionsSigned_start 
workbook, and save it as ProjectionsSigned. Then follow the steps. 

	 1.	 On the Start menu, click All Programs, click Microsoft Office, click Microsoft 
Office 2010 Tools, and then click Digital Certificate for VBA Projects.

The Create Digital Certificate dialog box opens.

	 2.	 In the Your certificate’s name box, type Excel2010SBS, and then click OK.

A message box indicates that the program created your certificate successfully.

	 3.	 Click OK.

The message box closes.

	 4.	 Click the File tab and then, if necessary, click Info. Click Protect Workbook and 
then click Add a Digital Signature.

A message box appears, offering the opportunity to view signature services on 
Office Marketplace.

	 5.	 Click OK.

The message box closes, and the Sign dialog box opens.

	 6.	 In the Purpose for signing this document box, type Testing.

	 7.	 Verify that the Excel2010SBS certificate appears in the Signing as area of the dialog 
box, and then click Sign.

The Signature Confirmation dialog box opens.

	 8.	 Click OK.

The Signatures task pane opens and the workbook is marked as final. If you edit the 
workbook, it will invalidate the digital signature, which is based on the workbook’s 
contents at the time you signed it.

CLEAN UP  Save the ProjectionsSigned workbook, and then close it.
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Saving Workbooks for the Web
With Excel, you can save your workbooks as Web documents, so you and your col-
leagues can view workbooks over the Internet or an organization’s intranet. For a docu-
ment to be viewable on the Web, it must be saved as a Hypertext Markup Language 
(HTML) file. HTML files, which end with either the .htm or the .html extension, include 
tags that tell a Web browser such as Windows Internet Explorer how to display the con-
tents of the file.

For example, you might want to set the data labels in a workbook apart from the rest of 
the data by having the labels displayed with bold text. The coding in an HTML file that 
indicates text to be displayed as bold text is <b>...</b>, where the ellipsis between the 
tags is replaced by the text to be displayed. So the following HTML fragment would be 
displayed as Excel in a Web page:

<b>Excel</b>

You can create HTML files in Excel by clicking the File tab and clicking Save As to display 
the Save As dialog box. To save a workbook as an HTML file, click the Save As Type arrow 
and then click Web Page. Then, in the Save As dialog box, select the Entire Workbook 
option, type a name for the file in the File Name box, and click Save to have Excel create 
an HTML document for each sheet in the workbook.

Tip  If the only sheet in your workbook that contains data is the one displayed when you save 
the workbook as a Web page, Excel only saves that worksheet as a Web page.

After you save an Excel workbook as a set of HTML documents, you can open it in your 
Web browser. To open the Excel file, start Internet Explorer, and then click Open on the File 
menu to display the Open dialog box. In the Open dialog box, click the Browse button to 
open the Windows Internet Explorer dialog box. You can use the commands in that dialog 
box to identify the file you want to open.

When you double-click the file you want to open, the Windows Internet Explorer dialog box 
closes and the file’s name and path appear in the Open box. To display the Excel workbook, 
click OK, and the workbook appears in Internet Explorer. You can move among the work-
book’s worksheets by clicking the sheet tabs in the lower-left corner of the page.

Saving a workbook to an organization’s intranet site enables you to share data with 
your colleagues. For example, Consolidated Messenger’s chief operating officer, Lori 
Penor, could save a daily report on package misdeliveries to her team’s intranet so that 
everyone could examine what happened, where the problem occurred, and how to fix 
the problem. It’s also possible to save a workbook as a Web file that retains a link to the 
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original workbook. Whenever someone updates the workbook, Excel updates the Web 
files to reflect the new content.

To publish a workbook to the Web, click the File tab, click Save As and then, in the Save 
As Type list, click Web Page. When you do, Excel displays the Publish button; clicking the 
Publish button displays the Publish As Web Page dialog box.

You can use the options in the Publish As Web Page dialog box to select which elements 
of your workbook you want to publish to the Web. Clicking the Choose arrow displays a 
list of publishable items, including the option to publish the entire workbook, items on 
specific sheets, or a range of cells. To have Excel update the Web page whenever some-
one updates the source workbook, select the AutoRepublish Every Time This Workbook 
Is Saved check box. You can also specify which text appears on the Web page’s title bar. 
To do so, click the Change button, type the page title in the Set Title dialog box, and 
click OK. When you save a workbook that has AutoRepublish turned on, Excel displays a 
dialog box indicating that the changes will update the associated Web file.

Important  When you save a PivotTable to the Web, the PivotTable doesn’t retain its interactivity. 
Instead, Excel publishes a static image of the PivotTable’s current configuration.

In this exercise, you’ll save a workbook as a Web page and then publish a worksheet’s 
PivotTable to the Web.

SET UP  You need the ShipmentSummary_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ShipmentSummary_start 
workbook, and save it as ShipmentSummary. Then follow the steps. 

	 1.	 Click the File tab, and then click Save As.

The Save As dialog box opens.
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	 2.	 In the File name box, type ShipmentSummaryWeb.

	 3.	 In the Save as type list, click Web Page.

The Save As dialog box changes to reflect the Web Page file type.

	 4.	 Click Save.

A warning message box appears, indicating that the workbook might contain 
elements that can’t be saved in a Web page.

	 5.	 Click Yes to save the workbook as a Web file.

The message box closes, and Excel saves the workbook as a Web page.

	 6.	 Click the File tab, and then click Close.

	 7.	 Click the File tab, click Recent, and then, in the list of recently viewed files, click 
ShipmentSummary.

The ShipmentSummary workbook opens.
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	 8.	 Click the File tab, and then click Save As.

The Save As dialog box opens.

	 9.	 In the File name box, type ShipmentSummaryPublish.

	 10.	 In the Save as type list, click Web Page.

The Save As dialog box changes to reflect the Web Page file type.

	 11.	 Click Publish.

The Publish As Web Page dialog box opens.

	 12.	 In the Choose list, click Items on Sheet2.

The available items on Sheet2 appear.

	 13.	 In the Item to publish list, click PivotTable.

	 14.	 Select the AutoRepublish every time this workbook is saved check box.

	 15.	 Click Publish.

Excel publishes the PivotTable to a Web page. Excel will update the contents of the 
Web page whenever a user saves the ShipmentSummary workbook.

CLEAN UP  Save the ShipmentSummary workbook, and then close it. Exit Excel.
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Key Points
●	 Sharing a workbook enables more than one user to view and edit the data at one 

time, which is useful in group projects in which each member has a distinct area of 
responsibility.

●	 Sending files by e-mail is a very efficient means of collaborating with colleagues. 

●	 Adding comments to cells is a quick way to let your colleagues know what you’re 
thinking without taking up valuable space in a cell.

●	 Tracking changes is vital when you share responsibility for a workbook with several 
other people.

●	 When your workbook’s data is too important to leave lying around in the open, use 
passwords to protect all or part of the file!

●	 Authenticating workbooks with digital signatures helps to identify the source of 
your files, so you won’t have to guess about the origins of that next attachment in 
your e-mail inbox.

●	 Saving a workbook as a Web-accessible HTML document is as easy as saving it as 
a regular Excel file, and opening a workbook saved for the Web is just as easy as 
opening any other Web page.

●	 Use the AutoRepublish facility to update Excel files on the Web. Whenever anyone 
changes the original workbook, Excel writes the edits to the HTML version of the file.
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